CompEvo Help

>> На главную
> Содержание справки
> Начинаем игру
> Начальное железо
> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды
> Содержание файлов

> Сайт игры

Здравствуйте, уважаемые игроки!

Перед вами находится 2-я версия справки к игре "Компьютерная революция". Этот "выпуск" справки написан для игры версии 3.5.5, и некоторые описанные в нем возможности не встречаются в ранних версиях.

Новое в этой справке:
  • Немного исправлена статья о начале игры (tnx haM3r)
  • Немного исправлена статья о добыче денег
  • Немного исправлена статья о характеристиках игрока
  • Исправлен один из скриншотов (tnx haM3r)
  • Добавлены три статьи (2 за авторством Сардора Пулатова, 1 - haM3r'а)
  • Исправлено множество орфографических (и пунктуационных) АШИППАК ошибок и ОЧЕПЯТОК опечаток
  • Добавлено описание двух новых плагинов (и вновь их авторы - Сардор Пулатов и haM3r)
  • Добавлено описание трех сайтов для игры (Вы не поверите, но автор одного из них снова haM3r!) - один из них не выложен как отдельный на Сайте игры, но он входит в состав мода Krsk
  • Добавлено описание модов (Как Вы думаете, есть ли здесь мод от haM3r'а?)
  • Исправлен порядок статей на странице Содержание справки

Иллюстрации в справке черно-белые для уменьшения "веса". Если Вы пришли в поисках ответа на какую-либо тему и не можете найти ее, посетите раздел Содержание справки, если же Вы новичок, рекомендуется просто проходить все разделы по порядку. Желаю Вам хорошей игры!

Все отзывы по справке пишите мне и Павлу на e-mail.

С уважением, Голубев "FLYM" Михаил
Справку сделал

Mailto: FLYM2005@GMAIL.COM


> На главную
> Начальное железо
> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды
>> Содержание файлов

> Сайт игры

Содержание файлов

Если у Вас есть списки оборудования или софта, подобного тому, который используется в Компьютерной эволюции, но вы не знаете, как добавить его в файлы игры, тогда в этом разделе вы найдете описание структуры большинства файлов. Между полями (напр. Название и Дата) !обязательно! делайте табуляцию (клавиша Tab на клавиатуре). Если вы добавили новое оборудование в игру, не поленитесь, пошлите файл Ревенкову Павлу на e-mail. ;-)
Видов платформ (ОС) в игре 5: Win, Lin, BSD, Be, OS2.

Data\Antispam.dat - список Противоспамных фильтров.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|")

Data\Antivirus.dat - список Антивирусов.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|") - Адрес сайта обновления

Data\AT.dat - список Корпусов.
Структура:
Название - Год выхода - Цена (д. е.)

Data\Broswer.dat - список Браузеров.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|")

Data\Cdrom.dat - список Оптических приводов.
Структура:
Название - Год выхода - Скорость записи DVD-R - Скорость записи DVD-RW - Скорость записи CD-R - Скорость записи CD-RW - Скорость чтения CD-ROM - Цена (д. е.)

Data\Cooler.dat - список Кулеров.
Структура:
Название - Год выхода - Цена (д. е.) - Количество оборотов в минуту - Уровень шума (дб)

Data\Cpu.dat - список Процессоров.
Структура:
Название - Год выхода - Цена (д. е.) - Производительность - Коэффициент умножения - Частота системной шины (МГц) - Чипсеты (разделяются знаком "|")

Data\Defragmenter.dat - список Дефрагментаторов.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|")

Data\Development.dat - список Сред разработки.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|") - Сокращенные названия языков (разделяются знаком "|")

Data\Firewall.dat - список Файрволлов.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|")

Data\Games.dat - список Игр.
Структура:
Название - Год выхода - Требуемая производительность видеокарты - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|")

Data\Hacking.dat - список Программ для хакерства.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|")

Data\Harddisk.dat - список Винчестеров.
Структура:
Название - Год выхода - Объем (Гб) - Скорость вращения шпинделя (rpm) - Цена (д. е.)

Data\Keyboard.dat - список Клавиатур.
Структура:
Название - Год выхода - Цена (д. е.)

Data\Manager.dat - список Файл-менеджеров.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|")

Data\Modem.dat - список Модемов.
Структура:
Название - Год выхода - Цена (д. е.) - Скорость (k)

Data\Monitor.dat - список Мониторов.
Структура:
Название - Год выхода - Цена (д. е.) - Относительная безопасность

Data\Motherboard.dat - список Материнских плат.
Структура:
Название - Год выхода - Чипсет - Смена частот (Y или N) - Смена напряжения на процессоре (Y или N) - Смена коэффициента умножения (Y или N) - Цена (д. е.) - Поддерживаемые шины для видеокарты

Data\Mouse.dat - список Мышей.
Структура:
Название - Год выхода - Цена (д. е.)

Data\OS.dat - список Операционных систем.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформа

Data\Power.dat - список Блоков питания.
Структура:
Название - Год выхода - Цена (д. е.)

Data\Printer.dat - список Принтеров.
Структура:
Название - Год выхода - Цена (д. е.) - Скорость (страниц в минуту)

Data\Ram.dat - список ОЗУ.
Структура:
Название - Год выхода - Цена (д. е.) - Объем (мб.) - Тип

Data\Scanner.dat - список Сканеров.
Структура:
Название - Год выхода - Цена (д. е.) - Скорость (страниц в минуту)

Data\Sound.dat - список Звуковых карт.
Структура:
Название - Год выхода - Цена (д. е.)

Data\Speakers.dat - список Колонок.
Структура:
Название - Год выхода - Цена (д. е.)

Data\UPS.dat - список Источников бесперебойного питания.
Структура:
Название - Год выхода - Цена (д. е.) - Надежность

Data\Videoboard.dat - список Видеокарт.
Структура:
Название - Год выхода - Чип - Производительность - Объем памяти (мб.) - Тактовая частота памяти (МГц) - Тактовая частота ядра (МГц) - Цена (д. е.) - Используемая шина

Data\Videosoft.dat - список Программ для разгона видеокарты.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|")

Inf\Asm.inf - код создаваемой на Ассемблере программы.

Inf\Bas.inf - код создаваемой на Basic программы.

Inf\Cpp.inf - код создаваемой на C++ программы.

Inf\Iwork1.inf - вопросы для первой категории (написанные в них деньги только выводятся пользователю, а выплачиваются ему другие, так что Вы не получите 1000000 д. е. :-)).

Inf\Iwork2.inf - вопросы для второй категории (написанные в них деньги только выводятся пользователю, а выплачиваются ему другие, так что Вы не получите 1000000 д. е. :-)).

Inf\News.inf - новости, время от времени выводимые пользователю.
Структура:
Новость - Год

Inf\Pas.inf - код создаваемой на Паскале программы.

Inf\Name.inf - имена игроков.

Inf\RW.inf - просьбы при пиратстве.

Inf\Spam.inf - спам, получаемый пользователем.

Inf\Text.inf - просьбы для сканирования/распечатки.

Inf\Unix.inf - каталоги взламываемых Unix-машин.

Inf\Windows.inf - каталоги взламываемых Windows-машин.

Sites\Адрес\page.ini - параметры сайта.
Caption=Заголовок сайта.
AddPoints=Изменяемый параметр при посещении сайта.
Count=На сколько этот параметр изменяется.
Подробнее в разделе: Создание сайта


> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
>> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды
> Содержание файлов

> Сайт игры

Хакерство

Для начала скажу, чтобы начать хакерство, нужно иметь статус не ниже Продвинутого. Также нет смысла хакерить, если у Вас не имеется файлового менеджера, как же Вы будете передвигаться по компу жертвы без него? Также в версии 3.5 хакерить не имеет смысла до 2003 года, т. к. только в этом году появляется так нужный нам Anti-firewall. Вообще их хакерского софта вполне достаточно переборщика паролей и анти-файрволла. Если Вы очутились в 2004 году, сразу купите и Stealth маскировку, она поможет Вам неописуемо долго быть на компьютере жертвы. Когда Вы находитесь на компьютере жертвы, Вы можете удалить папки (увеличение настроения), взломать некоторые программы (например, когда вы на компе с Windows, если Вам повезет и Microsoft не залатает свой софт), а также скачать так называемую "Секретную программу". Последнее (точнее, скорее всего, первое), что нужно помнить - это то, что лучше для хакерства себе на комп поставить Linux или BSD систему, т. к. под ними идут большинство хакерских программ.

Это было небольшое описание всего хакерства, теперь описание интерфейса. Когда Вы откроете окно хакерства ("Работа с интернетом" - "Хакерство"), перед Вами предстанет окно приветствия. Нажав кнопку "Программы" Вы можете купить нужные хакерские программы (табл. 2).

Таблица 2
Название | Дата выхода | Цена (д. е.) | Нужное семейство ОС | Вес (мб.)
Переборщик паролей | 2000 | 250 | Win, Lin, BSD | 8
Файл-бомба | 2001 | 314 | Lin, BSD | 10
Сетевой вирус | 2002 | 459 | Win | 4
Anti-firewall | 2003 | 519 | Win, Lin, BSD | 20
Stealth маскировка | 2004 | 753 | Lin, BSD | 45

После покупки направляйтесь в раздел "Соединение", если у Вас стоят переборщик паролей и anti-firewall, вы спокойно подключитесь. Теперь направляйтесь во вкладку "Хакерство", если у Вас есть Stealth-маскировка, включите ее (правая клавиша мыши, последний пункт в открывшемся меню), теперь можете спокойно, не торопясь смотреть папки, удалять, качать, взламывать.


> Как добыть деньги?
> Характеристики игрока
>> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды
> Содержание файлов

> Сайт игры

Железо, софт: краткое описание

Здесь представлено лишь краткое описание железа и софта, если Вы хотите сравнить одну железку с другой, посетите раздел Содержание файлов, в котором рассказано, как устроены игровые файлы, после этого вы сможете их просмотреть.
Железо
Необходимый комплект железа: Процессор, Материнская плата, Оперативная память, Жесткий диск, Монитор, Блок питания, Клавиатура, Мышь, Корпус.

Примечание: советы по выбору начального железа Вы можете найти соответственно в разделе Начальное железо

Для работы Вам этого достаточно, но рекомендуется еще купить модем, чтобы иметь возможность серфить в интернете.

Оптический привод нужен для установки программ, а также для пиратства (пишущий). Сканер и принтер нужны для удаленной работы. Видеокарту же можно сменить со встроенной на более хорошую для того чтобы играть.

Для покупки железа зайдите соответственно в пункт "Покупка железа", затем выбирайте, какой вид оборудования Вы хотите купить, откроется окно, в нем будет раскрывающееся меню с оборудованием, вышедшим в этом году в этой категории. После выбора оборудования вам покажут его характеристику, а также полосу стоимости, показывающую стоимость данного устройства по отношению ко всем вашим деньгам.

Если Вам не хватает денег, выберите в окне, вызывающимся по кнопке "Покупка железа", "Радиорынок", здесь товары дешевле, но они могут быть в плохом состоянии.

Если Вы хотите узнать насколько "крут" Ваш железный друг, нажмите в главном окне кнопку "Тест железа", скачается прога для теста, теперь она всегда будет на компе, и не надо будет заново качать, снова нажмите на кнопку "Тест железа", начнется тест, после этого Вам выведут результаты. Вы также в результатах можете разогнать процессор и видеокарту.

Чтобы полностью можно было управлять процессором, рекомендуется покупать материнскую плату со всеми 3-мя возможностями доступными. Теперь можете менять. Также если у Вас новый процессор Вы можете включить технологию Hyper-Threading. Что рекомендовал бы я: повышение FSB, дает ощутимый прирост, на Athlon 64 FX-55 FSB удавалось поднять на 40 вверх (без изменения других параметров). При повышенном FSB удалось повысить напряжение на 25, увеличение не дало абсолютно никаких преимуществ, зато разгонщик перестал "материться" о зависаниях компьютера. При манипулировании данным параметром нужно быть осторожным! Я лично сжег 3 процессора при этом. :-) Множителем можно манипулировать вместе с FSB, нужно достигнуть некой "золотой середины" между FSB и множителем. У меня лично получилось разогнать процессор с 2600 до 3302 МГц при значениях: FSB 254, Напряжение: 1,75, Множитель: 13. Наверняка, это не предел. Присылайте мне на e-mail Ваши разгоны вместе с параметрами.

Чтобы разгонять видеокарту, нужна программа для разгона, она покупается в окне, вызывающимся по одноименной кнопке в окне "Разгон видеокарты". Я бы порекомендовал Вам вначале автоматически выбрать оптимальные настройки, а затем немного повысить их, однако можно свободно экспериментировать, у видеокарты ничего не сгорит, не взорвется и т. д., а Вам любезно сообщат, что видюха не может работать с такими настройками

Софт
Большинство софта, кроме бесплатного и софта для пиратства, предоставляются в двух вариантах: лицензионный и нелицензионный. Они, в принципе, одинаковы, у обоих время от времени вылетает установка, но от лицензионки у Вас растет рейтинг. Есть несколько мест, где можно купить разные виды софта:
1. Щелкните "Программное обеспечение" в главном окне, здесь вы можете купить:
  • Операционную систему - она нужна для работы всего и вся.
  • Средства разработки - для создания собственных программ
  • Антивирус - для избавления от вирусов, которые могут "грохнуть" Вашу ОС со всеми программами
  • Противоспамные фильтры - если Вам надоел спам, поставьте противоспамный фильтр!
  • Брандмауер - нужен для защиты Вашего компьютера
  • Браузер - для серфинга по сайтам
  • Файловый менеджер - для перемещения по компьютерам жертв при хаке
Также в этом окне Вы можете дефрагментировать (если комп медленный) и форматировать (если у Вас на винчестере мало места) диск. Здесь же можно обновить антивирус и проверить свой компьютер на вирусы.

2. Хакерские программы, их можно найти в "Работа с интернетом" - "Хакерство" - "Программы". Их описания в разделе справки Хакерство.

3. Пиратские программы: "Работа с интернетом" - "Пиратство" - "Софт для пирата". Собственно, там есть описание всех программ, но на всякий случай оно приведено здесь:
  • CloneCD - главная утилита для пиратства, без нее ничего не получится, она копирует диски.
  • DivX - если Вы будете выполнять задания, где у Вас попросят фильм, эта прога - то, что Вам нужно
  • AudioGrabber - клиент просит

4. Программы для разгона видеокарты. Находятся: "Тестирование железа" - "Разгон видеокарты" - "Программа для разгона". Всего их две, ничем в принципе (кроме различия в 1 мб в весе) друг от друга не отличаются.


>> Начальное железо
> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды
> Содержание файлов

> Сайт игры

Начальное железо

Автор статьи: haM3r
Mailto: BVLAD36@BK.RU

Внимание! Версия статьи в справке весьма укорочена. Вы можете скачать оригинальную статью с Сайта игры.

Здесь приведен отрывок из статьи haM3r'а "Как заработать много денег..." (ее вы можете скачать с Сайта игры), посвященный теме выбора начального железа:

Игру Вы начнёте приблизительно с 4000-4300 де. Обычно этого не хватает на покупку компьютера в магазине, так что советую покупать самый дешёвый хлам. Привожу пример покупки в магазине, без скидок (для версии 3.5.3):

Таблица 3
Вид товара | Наименование | Магазин | Радиорынок
Материнская плата | Abit KT6 | 490 де | 466 де
Процессор | AMD Duron 700 MHz | 432 де | 410 де
Жёсткий диск | Seagate U4 6421 | 506 де | 476 де
Оперативная память | Corsair CAS | 379 де | 356 де
Видеокарта | ASUS V7100 | 516 де | 490 де
Оптический привод | Toshiba CD-M1402 | 428 де | 407 де
Монитор | Sony HMD-A400 | 801 де | 777 де
Клавиатура | Microsoft Natural | 89 де | 86 де
Мышь | Razer Boomslang | 139 де | 132 де
Блок питания | Sparkle 350W | 129 де | 123 де
Кулер | Alpha P125CM60 | 407 де | 391 де
Итого |  | 4316 де | 4114 де

Материнку, монитор и жёсткий диск лучше купить на радиорынке. Немного экономии не помешает. Правда, Вам могут подсунуть "битый" товар, поэтому, хотя, риск дело благородное, но сохраниться перед покупкой на радиорынке стоит. Кстати, неплохо покупать новые девайсы, когда в магазинах проходят скидки. Если денег на покупку компьютера не хватает, то можете взять кредит в банке. (IMHO очень полезная функция)


> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды
> Содержание файлов

> Сайт игры

Интернет

Интернет в игре, как и в реальности, предоставляет много возможностей.
Сайт и e-mail
От них растет ваш рейтинг, на этом польза заканчивается. Минусы: на e-mail часто приходит спам, если какой-нибудь извращенец зашлет Вам большой файл, придется платить денежки за трафик.
Различные виды заработка
4 различных вида заработка принадлежат интернету. Это ответы на вопросы, хакерство, пиратство и сканирование/распечатка. Подробнее о них Вы можете прочитать в разделе Как добыть деньги?
Просмотр сайтов
В версии 3.5 число сайтов в World Wide Web Компьютерной эволюции ограничивается двумя:
  • http://www.shtirlitz.ru/ - развлекательный сайт с анекдотами, повышается настроение;
  • http://www.strashilki.ru/ - тоже развлекательный сайт, но со страшилками, повышается настроение.
Следующие моды Вы можете скачать с Сайта игры
  • http://www.happy.ru/ (by haM3r) - сайт будет радовать Вас=) Но что странно - если я ввожу имя, то после показа всех алертов, CompEvo зависает, но в браузере все ок....
  • http://www.ad.ru/ (by Ревенков Павел) - а этот сайт порадует Вас тремя баннерами и 25 д. е.
  • http://www.catalog.ru/ (by KRSK) - вкходит в состав мода krsk, на нем есть ссылки на все сайты CompEvo, при этом у Вас поднимается рейтинг!


> Как добыть деньги?
>> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды
> Содержание файлов

> Сайт игры

Характеристики игрока

В этом разделе будут рассмотрены основные характеристики: рейтинг и статус, настроение, а также отношение властей.
Рейтинг и статус
Статус напрямую зависит от рейтинга, он нужен только для подчеркивания определенных уровней, так что реальным параметров является рейтинг. Рейтинг можно заработать, покупая железо, лицензионный софт, от своего сайта в интернете вам идет постоянное повышение, то же самое и от e-mail, но помедленнее. Также рейтинг дается за посещение некоторых сайтов. За успешное написание программ вам также идет рейтинг. Рейтинг нужен для хака (когда рейтинг поднимет статус до "Продвинутый"), а также для устройства на работу.
Настроение
Не удалось скомпилировать программу и пришлось искать DLL? Пропалили при хаке? Испорченные болванки? Обманули при сканировании/печати? Или еще какие обстоятельства? Так ведь и умереть можно! Для повышения настроения идем в пункт "Отдых и развлечение", также в "Отдыхе и развлечениях" можно поставить игры на свой комп и играть в них, конечно же, если у Вас хорошая видеокарта. Настроение можно повышать также, удаляя папки на чужих компьютерах при хакерстве и посещая юмористические сайты ("Работа с интернетом" - "Выход в интернет"), естественно есть и плагины для улучшения настроения. Ну и, конечно, если в Вашей компьютерной жизни все хорошо и удается - настроение будет соответствующим.
Отношение властей
Если Вы часто попадаетесь на хаке и пиратстве, власти будут Вас, мягко говоря, недолюбливать. Исправить это можно, сдавая властям пиратский народ (см. подробнее в разделе Как добыть деньги?)


> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
>> Моды
> Содержание файлов

> Сайт игры

Моды

Для начала определимся с тем, что же мы будем понимать под словом "мод". В CompEvo мод - это несколько игровых файлов с измененными/дополненными настройками, которые изменяют в основном какие-либо нюансы игрового процесса, например, добавление новых ОС, изменение ОС, под которыми идут программы, изменение железа и т. д.
Если честно, я побоялся ставить все это себе на CompEvo, но анализ файлов рассказывает все о каждом моде=)
Описание модов

Название Universal Mod v1.4
Краткое описание автора

  • Теперь игровое окно можно свернуть в SystemTray
  • Теперь все материнские карты поддерживают возможность смены частот шины FSB, напряжения на процессоре, коэффициента умножения на процессоре.
  • Добавляются новые OS и среды разработки.
  • Добавляются новые антивирусные программы.
  • Теперь все программы можно поставить на любую OS.
  • Добавляется способность проигрывать WAV и MP3 файлы.
  • Языки линейки C и Pas теперь взаимо заменяемые.
  • В игру добавляется новая музыка.
  • Изменены примеры програмных кодов.
  • Расширены каталоги удалённых систем.
  • В игре изменяются графические файлы.
Автор haM3r
Награды Универсальный мод=)) | Лучший мод
Альтернативное описание Уже немного устаревший мод (может глючить с новыми версиями CompEvo, например из-за отсутствия сайтов у антивирусов), но все еще самый лучший мод. Собственно его полностью описал автор, хотелось бы добавить толька то, что с модом идет воистину крутейший bat'ник-установщик! Единственное, что я не понял - зачем нужно это: Отчищаются файлы "Players.inf" и "Records.inf"???

Название Linux
Краткое описание автора Благодаря этому моду софт и игры можно поставить на Linux.
Автор Кольцов Артём
Награда Пингвиний мод
Альтернативное описание Ну... На самом деле не весь софт можно поставить на Linux благодаря этому моду, только софт для программирования... В принципе хороший мод, но сказывается его дата выпуска - Ноябрь 2004 => неполный список софта для программирования и неполный список игр.

Название Krsk
Краткое описание автора

  • 2 новых Total Commander.
  • Два новых рисунка.
  • Сайт-каталог сайтов.
  • Скин с иконками CooL.
Автор KRSK
Награда Хороший мод
Альтернативное описание Несмотря на немногочиленные функции, мод очень хороший. Сайт весьма полезен, но есть есть некоторые недоработки в CompEvo, из-за которых возникают некоторые проблемы. Скин лично мне очень понравился, очень стильный, теперь он у меня висит, пока не найду что-нибудь еще лучшее=) Насчет рисунков есть два вопроса: насчет первого - почему там два раза повторяется Basic, насчет второго - можно узнать, где уже появился CompEvo 4?=))

Название FromSardor
Краткое описание автора

  • Теперь игровое окно можно свернуть в SystemTray!
  • Изменены сайты 404 и hacked.
  • Изменён код pas.inf.
  • Поддежка mp3 музыки.
  • Удаляютса все имена которыми играли.
  • Удаляютса все рекорды.
  • Изменяются 2 ресунка
  • Исправлены в анти-вирусах некоторые веши.
Автор Сардор Пулатов
Награда Перспективный мод
Альтернативное описание Для начала хочется сказать, что попахивает это все Universal Mod'ом, и действительно, автор говорит, что научился делать моды на основе мода haM3r'а. Мод достаточно полезен, но нужно бы его немного доразвить... Также как и в Universal Mod'е не понял, зачем нужны эти функции: Отчищаются файлы "Players.inf" и "Records.inf"? Также хочется заметить, что раз автор уменьшил размер антивируса до 11 мб (реальный размер), может тогда и сделаем размеры всех файл-менеджеров реальными? Тогда у многих даже 1 мб не будет! Идея насчет смены сайтов 404 и hacked весьма свежа, никто еще не делал моды с этой функцией, но исполнение новых сайтов оставляет желать лучшего, а ведь знаете, какие это произведение искусства - дефейсы? Некоторые месяцами над одним дизайном работают...


>> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды
> Содержание файлов

> Сайт игры

Как добыть деньги?

Вопрос добычи денег в игре CompEvo не стоит очень остро, так как способов множество, здесь будут рассмотрены все из них.

1. Работа
На работе Вам выплачивают ежемесячно зарплату. Посмотреть зарплату можно в списке работ. Здесь все должно быть просто: до 10 числа текущего месяца в главном окне кликаем по кнопке "Поиск работы", перед Вами список должностей, выбираем одну из доступных и жмем "Наняться". Вначале доступны не все работы, для открытия более хороших должностей нужно копить опыт (он же рейтинг), в разделе Характеристики игрока о рейтинге написано поподробнее. Кроме дохода работа не дает практически никаких преимуществ, только работа сис-админом и выше позволяет Вам писать программы.

2. Программирование
При максимальных знаниях, это, наверное, самый крупный источник дохода.

Для начала откройте "программное обеспечение" из главного окна, далее нажмите кнопку "Создание программ". Перед Вами окно программирования. Для начала зайдите по закладке "Повышение квалификации", если у Вас хватит денег, пройдите все курсы, это потом окупится. Если же нет, пройдите сколько сможете. Теперь переходите в "Написание программ", Вам предложат выбрать среду разработки, рекомендуется выбирать ту, которая у Вас установлена, т. к. при выборе иной Вы наверняка не сможете нормально написать программу. Теперь жмите кнопку "Поехали!". Вам предложат написать название своей программы. После его ввода Вы можете написать исходный код и, если у Вас хватает знаний в программировании, еще DLL. DLL является хорошим способом расширить возможности вашей программы. После этого нажмите "Компилировать". В процессе компиляции могут возникать ошибки, внизу в группе "Отладка" есть возможные варианты действия. После успешной компиляции в зависимости от Ваших знаний Вам будут выплачены деньги.

3. Пиратство
Здесь тоже все достаточно просто. Открываете "Работа с интернетом" из главного окна, щелкаете по кнопке "Пиратство" и вот вы здесь. Для начала закупитесь программами для пиратства ("Софт для пирата"), затем сходите на базар и прикупите болванок, теперь смело идите в пункт "Займись делом наконец!". Ах да, еще Вам нужен пишущий привод! Там Вы можете выбрать какую заявку будете выполнять, затем если вы катаете или фильм, или музыку, для начала нужно или сжать, или перегнать. (Кстати, чтобы закатать фильм Ваш оптический привод должен писать DVD, а также у Вас должно быть 5 Гб места на жестком диске, для музыки достаточно 1 Гб места) Затем жмите "Скопировать..." и процесс пошел. В первом столбике пишется скачка файл (или, если музыка или фильм перегоняются, то процесс кодировки), во втором использование процессора, в третьем запись на диск. Иногда случается, что болванки запорчены, ничего с этим не поделать... Также если вы будете очень много пиратить, власти обратят на Вас внимание, чтобы исправить положение Вам придется "постукачить", т. е. Вы можете нажать кнопку "Сообщить властям", они будут вам благодарны. Однако иногда случается так, что после сообщения властям к Вам в дверь стучатся два амбала и Вам придется дать им денежек.
4. Сканирование и распечатка
Для выполнения этих заданий нужно запастись принтером и сканером. После произведения покупок направляемся "Работа с Интернетом" - "Сканирование и распечатка". Далее выбираем работу по вкусу и жмем соответственно "Сканирование" либо "Распечатка". Ждем и, если клиент оказался добропорядочным (что случается далеко не всегда), получаем денежки.
5. Хакерство
Хак подробно рассмотрен в разделе "Хакерство". Если повезет, это вполне неплохой источник дохода и улучшения настроения.
6. Ответы на вопросы
Идем в "Работа с интернетом", затем в "Ответы на вопросы", там есть две секции: "Перевод" - там вам нужно перевести слово, предложение или расшифровать аббревиатуру; "Вопросы для профи" - вопросы, связанные с компьютерами. Обе секции вопросов достаточно легкие, так что зарабатывать деньги вполне реально.
7. Плагины
Пока что плагинов для заработка немного, но, например, в моем (это не реклама, заметьте!) плагине "Бар" Вы можете заработать денег. Также недавно появился плагин "Твикер" от haM3r'а, в котором можно отредактировать количество денег.
8. Банк
Из главного окна игры вызовите окно "Банк", выберите количество денег, которые Вы хотите вложить и нажмите кнопку "Вклад", теперь Вы будете получать от банка ежегодно проценты (они написаны в том же окне).
9. Банк 2
Деньги в банк можно не только вкладывать, но и занимать у него. Для этого направляйтесь в окно "Банк", выбирайте сумму, время, на которое хотите занять деньги, затем жмите кнопку "Занять". Желательно деньги к тому сроку отдать, иначе вам будет натекать Пеня, которую тоже придется оплатить. Узнать сколько осталось времени до выплаты можно, наведя мышь на размер кредита в группе "Банк" в главном окне.
10. Случайный заработок
Время от времени Вам будут выдаваться сообщения о том, что Вы нашли кошелек, выиграли в лотерее деньги, получили посылку или сделали какую-то работенку. Несерьезный способ заработка.
11. Читы
К игре есть приличное число читов, в том числе и на деньги, однако Вы их узнаете только после прохождения игры.


> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
>> Музыка в любом формате
> Моды
> Содержание файлов

> Сайт игры

Установка музыки в любом формате

Автор статьи: Пулатов Сардор
Mailto: SARDOR90@GMAIL.COM
URL: RPPROGSFROMSADOR.NAROD.RU

Редактор-корректор: FLYM

Внимание! Версия статьи в справке весьма изменена. Вы можете скачать оригинальную статью с Сайта игры.

Для начала у Вас, конечно же, должна быть музыка в каком-либо формате. В нашем примере это будет mp3.
Зайдите в директорию с игрой. В ней есть файл Config.ini, откройте его любым текстовым редактором. В этом файле есть строчка, начинающаяся с "MusicFormats=", у меня она 7-я. После знака "=" (или можно в конце строки, но тогда знак ";" должен быть перед расширением музыки) пропишите "*.формат_Вашей_музыки;", например, "*.mp3;". Сохраните и закройте этот файл.

Теперь скопируйте музыку в формате, который Вы указали в файле Config.ini, в папку Music, находящуюся в директории с игрой, при этом переименуйте свой музыкальный файл в "Music N", где N - число от 1 до бесконечности, обозначающее номер вашей композиции.

Вот и все, теперь в игре есть Ваша музыка.


> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды
> Содержание файлов

> Сайт игры

Плагины: что? зачем? как?

Плагины были введены в игру в версии 3.3 Beta 1. Их пока что не очень много, но если Вы умеете программировать, на Сайте игры выложено руководство по созданию плагинов. Вообще плагины добавляют в игру некоторые новые функции и расширяют ее. Ниже в этом разделе описаны плагины, доступные на момент написания на Сайте игры. После скачивания распакуйте плагин (если он заархивирован) в папку Plugins в директории с игрой. После этого запустите Компьютерную эволюцию и загрузите/начните новую игру. Зайдите в меню с буквой "K", выберите пункт "Настройки", затем "Плагины", выберите желаемый плагин и запустите его (щелчок по кнопке "Запуск", либо нажатие Enter, либо двойной щелчок по названию плагина).
Описание плагинов

Название Арканоид
Описание автора Незамысловатый арканоид. При условии выигрыша сильно повышается настроение.
Автор Ревенков Павел
Награда Игровой плагин
Альтернативное описание Как правильно подмечено автором "незамысловатый арканоид": у Вас есть дощечка, шарик, игровое поле и потолок. Потолок по немного опускается, Ваша цель - не дать мячику упасть пока потолок не опустится до минимальной высоты. Если Ваше игровое настроение никуда не годится или Вы просто устали играть (ну и сказал я :-)), в этом плагине Вы можете немного развлечься

Название Бар
Описание автора Бар, где можно не только развлечься, но и подучиться
Автор FLYM (Голубев Михаил)
Награда Мой плагин=)))
Альтернативное описание Оценивать свой же плагин это слишком, так что просто дам немного более полное описание: в плагине Вы можете выпить, послушать анекдоты от бармена, сыграть в игру, подобную арканоиду Павла, но немного измененную (у вас теперь две дощечки), сыграть в кости, поставить на таракана в тараканьих бегах, пропустить месяц в работе на некого мистера Брауна, а также немного увеличить свой рейтинг (за деньги, конечно). Как кто-то верно подметил, плагин похож на текстовые квесты в Космических рейнджерах. Временно заморожен (примерно до августа 2005)

Название OSUpdate
Описание автора Обновление операционной системы для защиты от вирусов и атак из интернета.
Автор Ревенков Павел
Награда Полезный плагин
Альтернативное описание Пока что плагин не встроен в игру, но я считаю, что это просто жизненная необходимость. :-) Конечно можно переставлять ОС из-за наглых вирусов и хакеров, но гораздо проще поставить этот плагин и время от времени обновлять свою ОС, забыв о том, что такое переустановка операционки!

Название SpeedChanger
Описание автора Данный плагин позволяет изменять скорость игры в часах без перезапуска.
Автор Ревенков Павел
Награда Быстрый плагин
Альтернативное описание Плагин, хоть и не обладает великой функциональностью, но он однозначно musthave. Поверьте, когда-нибудь Вам нужно будет зачем-нибудь сменить скорость игры. Без этого плагина придется перезапускать игру, затем снова перезапускать, чтобы вернуть скорость обратно, плагин избавит Вас от этой проблемы.

Название Твикер
Описание автора Плагин, позволяющий без особых усилий поменять некоторые данные
в игре.
Автор haM3r
Награды Читерский плагин | Лучший плагин
Альтернативное описание Нет, лучший он не потому что читерский, он действительно лучший! Запустив этот плагин, я просто обомлел: красивый дизайн в черно-зеленых тонах, а также функции, совершенно не схожие с теми, которые, как я полагал, будут в нем. Однозначно мастхэв для читера! Ну и пара слов о самом плагине: он позволяет Вам поменять Количество наличных денег, Вклад в банке, Процент в банке, Вашу зарплату, Имя, Рейтинг, Настроение, Отношение к Вам властей, Скорость течения времени, Возраст. При этом плагин заботливо запоминает, какие были данные при его запуске, и если Вы все-таки решите сойти с пути читера, всегда можно нажать на кнопку "default". Единственное, что мне до сих пор не понятно: зачем в плагине кнопки запуска Windows'овского Калькулятора и Блокнота?

PS Ах да, если вы забыли адрес сайта CompEvo, зайдите в справку плагина=)

Название О разгоне
Описание автора Поможет вам узнать о разгоняемости видЕокарты и процессора без чит кодов
Автор Сардор Пулатов
Награда Минималистический плагин
Альтернативное описание Все прям как сказал автор: при запуске плагина высвечивается единственный MessageBox, в котором написаны разгон видеокарты и разгон процессора. Единственное, что бы хотелось отметить: видЕокарта пишется через Е.


> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
>> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды
> Содержание файлов

> Сайт игры

Создание сайта

Автор статьи: Пулатов Сардор
Mailto: SARDOR90@GMAIL.COM
URL: RPPROGSFROMSADOR.NAROD.RU

Редактор-корректор: FLYM

Внимание! Версия статьи в справке весьма изменена. Вы можете скачать оригинальную статью с Сайта игры.

Сайты в игре Компьютерная Эволюция появились недавно (с версии 3.5.0). В ней есть только 2 сайта "shtirlitz.ru" и "strashilki.ru" (на сайте есть еще 3 - прим. ред.), но вы можете поставить туда и свой сайт, это не трудно.

Вам понадобится:
  • Любой текстовый редактор (например, Блокнот)
  • Знание HTML (или Вы можете воспользоваться визуальным редактором html)
  • Прямые руки - прим. ред.

Итак, поехали. Для начала создадим папку, например rpprogs.narod.ru в директории Sites, которая находится в папке игры, название этой создаваемой директории будет адресом нашего сайта. Далее давайте создадим страницу, которая будет называться, page.htm (название должно быть именно таким! - прим. ред.) Наберите в текстовом редакторе код страницы и сохраните в файл page.htm. Простейший пример кода страницы:

<HTML>
<BODY>
<H1>Это пример</H1>
</BODY>
</HTML>

После создания страницы в одной папке с ней создайте файл page.ini:

[Options]
Caption=Заголовок
AddPoints=Money
Count=25

[About]
Comment=Комментарий
Author=Автор
Mail=E-mail автора

Замените все параметры на свои.
Описание параметров:

  • Caption - заголовок сайта
  • AddPoints - что добавляется при посещении сайта:
    1. Mood - Настроение
    2. Money - Деньги
    3. Programming - Рейтинг
  • Count - как изменяется предыдущий параметр (число)
  • Comment - комментарий к сайту
  • Author - автор сайта
  • Mail - e-mail автора

Теперь вы знаете как делать сайты в CompEvo;)


>> Начинаем игру
> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды
> Содержание файлов

> Сайт игры

Начинаем игру

Итак, Вы запустили Компьютерную эволюцию, перед вами окно, которое вы можете увидеть на рисунке справа. В нем Вы должны будете ввести свое имя (если оно не будет введено, Вас нарекут Мистером Х), по желанию вы можете указать путь к файлу-изображению, который будет использован как Ваше фото, укажите свой игровой возраст (желательно не ставить ниже 16, т. к. в банк нельзя попасть до этого возраста), а также Вас попросят выбрать скорость течения игры. После выполнения этих действий нажмите кнопку "Поехали!" для начала игры.
После нажатия кнопки "Поехали!" Вы попадете в главное окно программы. В нем вы можете видеть множество групп с характеристиками Вас и Вашего мнимого компьютера. Они собраны в группы (табл. 1). Каждую группу, кроме "Управление игрой" можно свернуть, щелкнув по заголовку, чтобы распахнуть группу обратно, снова щелкните по заголовку

Чтобы открыть меню игры нажмите на кнопку с буквой "K" (На стандартном скине "Keramik", на других может быть иное обозначение меню), здесь Вы можете начать новую игру, включить паузу (она будет включена, пока Вы не нажмете кнопку "OK"), загрузить сохраненную игру, сохранить игру (рекомендуется сохранять игру под тем же именем, что и игрок, тогда при выборе этого игрока автоматически будет грузиться игра), посмотреть рекорды (т. е. игрока, дожившего до 2005 года и его характеристики), изменить настройки (включение/выключение: автоматического сохранения, музыки, новостей, прозрачности; также Вы можете переключаться между оконным и полноэкранным режимами, проверить обновления или включить автообновление, изменить скин или включить плагин (скины и плагины можно скачать с сайта RPPROGS.NAROD.RU), посмотреть историю игры, посмотреть информацию об игре и выйти из нее.

Таблица 1
Ваш компьютер | Здесь Вы можете увидеть какое оборудование установлено на Вашем компьютере. Поднеся мышь к названию какого-либо устройства, вы можете узнать его характеристики: напр., объем ОЗУ, объем винчестера и количество оставшегося свободного места.
Установленные программы | Названия установленных у Вас ОС, Среды разработки (для написания программ), Антивируса (поднеся мышь к его названию можно узнать дату последнего обновления), Противоспамного фильтра, Брандмауера (для защиты компьютера), Дефрагментатора диска, Браузера (для просмотра сайтов) и Файлового менеджера (для просмотра папок чужого компьютера при взломе).
Интернет | Вы можете увидеть свой сайт в интернете и e-mail, если они у Вас, конечно есть. Также здесь написано количество полученного Вами спама.
Ваш статус | Здесь показываются Ваш возраст, моральный дух, работу, денежные средства, рейтинг, статус и отношение к Вам властей. При поднесении мыши к полосам состояния настроения, рейтинга и отношения властей вы можете узнать более точную информацию.
Хакерство | В этой группе можно посмотреть, сколько хакерских программ приобретено, сколько раз Вас арестовывали, а также количество удачно взломанных компьютеров. При наведении мыши на число взломанных компьютеров Вам покажут, сколько из них были на Windows, а сколько на Unix; наведя мышь на число программ, Вам покажут какие это программы.
Пиратство | Здесь показаны установленные программы для пиратства, количество пустых болванок и количество записанных Вами дисков (наведя мышь на это число, вы узнаете число запорченных болванок)
Программирование | Здесь Вы можете узнать какие языки программирования Вы знаете, а также, сколько вы программ написали.
Банк | Здесь написаны Ваши вклад, кредит и проценты банка.
Управление игрой | Игровое меню, при помощи которого вы можете купить железо, софт, тестировать железо, работать с интернетом, искать работу, отдыхать, направиться в банк, а также посмотреть новости, такие как акции в магазине.
Данные по материнской плате, процессору и видеокарте | В этих трех группах вы можете узнать дополнительные данные о вашей материнской плате, процессоре и видеокарте.
Скины
Информация про скины помещена в этом разделе, т. к. устроить рабочее место по своему вкусу - это первое, что должен сделать каждый. На Сайте игры Вы можете скачать скины по своему вкусу. Если же Вы и сами имеете в себе талант дизайнера, качайте с того же сайта и Изготовитель скинов. Делайте свои скины! Если скин будет хорошим, место на сайте ему обеспечено! :-)
Обновление
Не забывайте время от времени обновлять программу, это можно сделать на Сайте игры, однако, если Вам лень постоянно заходить на сайт, в меню настройки Вы можете проверить игру на обновления, а также включить режим автообновления, который будет время от времени проверять, есть ли в интернете новые версии игры. И помните! Вместе с каждой версией в игре становится меньше багов и больше возможностей!

Итак, в этом разделе справки Вы кратко ознакомились с главным окном игры и теперь можно смело начинать играть, более подробную информацию можно найти в других разделах.


> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды
> Содержание файлов

> Сайт игры

Содержание справки

Если Вы не можете найти интересующую Вас тему в справке, в этом разделе обозначены большинство из них (в алфавитном порядке) с указанием разделов. Если вы хотите найти что-либо на этой странице, нажмите Ctrl+F и введите часть слово, например, чтобы найти пункт "Создание программ", наберите "прог" или "созд" и т. п.

E-mail - Интернет
MP3 - Музыка в любом формате
Арканоид -Плагины: что? зачем? как?
Бар - Плагины: что? зачем? как?
Вклад денег в банк - Как добыть деньги?
Выбор возраста - Начинаем игру
Выключение музыки - Начинаем игру
Главное меню - Начинаем игру
Главное окно - Начинаем игру
Деньги - Как добыть деньги?
Игры - Характеристики игрока
Изменение главного окна - Начинаем игру
Изменение скорости игры - Плагины: что? зачем? как?
Железо - Железо, софт: краткое описание, Начальное железо
Загрузка игры - Начинаем игру
Кредит в банке - Как добыть деньги?
Моды - Моды
Своя музыка - Музыка в любом формате
Начало игры - Начинаем игру, Начальное железо
Необходимое железо - Железо, софт: краткое описание
Обновление - Начинаем игру
Обновление ОС - Плагины: что? зачем? как?
Описание софта - Железо, софт: краткое описание
Ответы на вопросы - Как добыть деньги?
Отношение властей - Характеристики игрока
Пауза - Начинаем игру
Пиратство - Как добыть деньги?
Плагины - Плагины: что? зачем? как?
Программирование - Как добыть деньги?
Проверка на вирусы - Железо, софт: краткое описание
Работа в интернете - Как добыть деньги?
Работа в реале - Как добыть деньги?
Разгон видеокарты/процессора - Железо, софт: краткое описание, Плагины: что? зачем? как?
Редактирование игровых файлов - Содержание файлов, Создание сайта, Моды
Рейтинг - Характеристики игрока
Рекорды - Начинаем игру
Сайты - Интернет
Свой сайт - Интернет
Сканирование и распечатка - Как добыть деньги?
Скины - Начинаем игру
Случайный доход - Как добыть деньги?
Создание программ - Как добыть деньги?
Создание сайта - Создание сайта
Софт - Железо, софт: краткое описание
Софт для пирата - Железо, софт: краткое описание
Софт для хакера - Хакерство
Сохранение игры - Начинаем игру
Статус - Характеристики игрока
Тест железа - Железо, софт: краткое описание
Улучшение отношения властей - Как добыть деньги?
Читерство - Плагины: что? зачем? как?
Читы - Как добыть деньги?